1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #25126 (closed: knowledgebase)

Opened 2 years ago

Last modified 23 months ago

FRS group permission incorrect for the mingw project

Reported by: earnie Owned by: ctsai
Keywords: PEND Cc: mingw-dvlpr@…
Private: no

Description

Summary: FRS group permission incorrect for the mingw project

/home/frs/project/m/mi/mingw is showing a group ownership of root and it should be a group ownership of mingw for all directories and files in that directory recursively. Also the group permissions should contain the write bit on all files and directories in that directory recursively. This is preventing our members from releasing new software updates.

Change History

Changed 2 years ago by keithmarshall

Yet another SF cock-up, I fear! One for which someone at SF should be keel-hauled, (from stem to stern of the Queen Mary II, for preference, rather than the more traditional, yet less punitive athwart-ships variant).

I'm getting a strong feeling of déja vu here; I've already been through the exercise of changing the permissions on everything I own, just a few months ago. IIRC, last time around everything was mode 644, owned by me, (or whoever else), and the group was mingw. I used sftp's 'chmod 664 *' to reset everything I owned appropriately. On that occasion, I got messages to say that permissions were being changed for the files which I owned, and error messages in respect of each file owned by others. A subsequent sftp 'ls -l' confirmed that mode 664 had been applied, to each of my files.

Today, I see that all permissions have reverted to mode 644, and that the group has *changed* to root. Furthermore, the sftp chmod command, which did work previously, now reports success in respect of *every* file, regardless of ownership, yet it actually does NOTHING AT ALL; every file remains, stubbornly, at mode 644.

Changed 2 years ago by ctsai

  • keywords PEND added
  • owner set to ctsai
  • status changed from new to assigned

Greetings,

I don't know if you've seen the site status post on the upgrades to the permissions system, but perhaps this requires some further explanation. The permissions system now matches what's been used with the Project web system since Feb 2011, which means that the standard UNIX permissions aren't what our system checks when determining what privileges users have.

As noted in the site status post above, what we actually check against currently is the "Shell Access" permission. I suspect that the users that are having permissions issues have "Release Technician" privileges, but not "Shell access". I don't think a final decision has been made in regards to the release technician permission moving forward, but from here on out, you no longer need to tweak any of the standard UNIX permssions (like the user and group ownership, or the "chmod" value), and for the time being anyway, setting the "Shell access" permission should resolve permissions issues for individual developers.

Please let me know if you have further questions, or if things are not working as I describe.

Thanks!
Chris Tsai, SourceForge.net Support

Changed 23 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to knowledgebase

As I haven't heard back from you, I assume that this is clear. If you have further questions, please don't hesitate to let me know.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.