1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #24230 (closed: fixed)

Opened 2 years ago

Last modified 2 years ago

Default Mercurial Changroup Hook error

Reported by: jcr13 Owned by: burley
Keywords: SOG Cc:
Private: no

Description

This has been happening for the past few days. As far as I know, it's a new problem (been using Mercurial for about a year on SourceForge without seeing it). Here's a log:


jcr13@montreal:~/cpp/CastleDoctrine/gameSource$ hg push
Password:
pushing to ssh://jcr13@hcsoftware.hg.sourceforge.net/hgroot/hcsoftware/CastleDoctrine
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 4 changesets with 21 changes to 14 files
remote: Running changegroup hook
remote: Use of uninitialized value in concatenation (.) or string at /etc/mercurial/changegroup line 57.
remote: Use of uninitialized value in concatenation (.) or string at /etc/mercurial/changegroup line 57.
remote: Use of uninitialized value in concatenation (.) or string at /etc/mercurial/changegroup line 57.
remote: Use of uninitialized value in concatenation (.) or string at /etc/mercurial/changegroup line 64.


I haven't modified the changegroup hook, so I think this is a problem with the default configuration. (In fact, I don't even have access to /etc/mercurial/changegroup from my shell account.)

Change History

follow-up: ↓ 2   Changed 2 years ago by ctsai

  • keywords SOG added; mercurial changegroup hook removed
  • owner set to burley
  • status changed from new to assigned

Thank you, I've confirmed this issue and I'm escalating this to our operations team to investigate.

Regards,
Chris Tsai, SourceForge.net Support

in reply to: ↑ 1   Changed 2 years ago by apnadkarni

Just to corroborate - I am also seeing this error on all four of my Mercurial based projects.

  Changed 2 years ago by cambridge

As per ticket #24370, I am also getting the same error and have been getting it for at least 2-3 weeks, although prior to that hadn't pushed since November 21st so the change at the SourceForge end may have occurred anytime after that.

  Changed 2 years ago by thomas_ah

/etc/mercurial/changegroup contains the line:

$cwd =~ m!^/hgrepo/./../([^/]+)/([^/]+)!;

But cwd at this point is /hgroot/PROJECTNAME/REPONAME
So it would probably work with:

$cwd =~ m!^/hgroot/([^/]+)/([^/]+)!;

  Changed 2 years ago by ctsai

  • status changed from assigned to closed
  • resolution set to fixed

Greetings,

This should be fixed now. If you're still having problems, please open a new ticket.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.