1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #23192 (closed: self-service)

Opened 2 years ago

Last modified 2 years ago

nssdb mercurial repo

Reported by: cambridge Owned by:
Keywords: Cc:
Private: no

Description

Hi,

I recently created the nssdb project with a Mercurial repository.

When I first tried to commit code to my new nssdb Mercurial repo today, I got the error:

$ hg clone ssh://cambridge@nssdb.hg.sourceforge.net/hgroot/nssdb/code
remote: abort: There is no Mercurial repository here (.hg not found)!

So I tried this instead and it worked:
$ hg clone ssh://cambridge@nssdb.hg.sourceforge.net/hgroot/nssdb/nssdb

I then successfully pushed 187 files to the repo.

However, when I try to browse the repo on the web, it's empty. It appears to be trying to show me the "code" URL, the first one I tried above which failed. When I go into my Admin pages, and try to change the mount point for Mercurial to "nssdb", I get an error saying that it is already in use.

Please can you fix this so that the files I committed to the repo can be viewed in my browser at the nssdb/nssdb URL.

Thanks,
Mark.

Change History

Changed 2 years ago by ctsai

  • status changed from new to closed
  • resolution set to self-service

You pushed to the wrong repository, the correct URL that you should be using for the repository (as stated on the code browser page) is: ssh://cambridge@hg.code.sf.net/p/nssdb/code

Regards,
Chris Tsai, SourceForge.net Support

Changed 2 years ago by cambridge

Hmmmm, so which repo did I push to then? I've tried your new URL, it's going through at the moment.

I think you need to update your support docs, because I followed them to the letter:
http://sourceforge.net/apps/trac/sourceforge/wiki/Mercurial#GettingStarted

Changed 2 years ago by ctsai

I assume that you missed the notice at the top of that documentation page.

Regards,
Chris Tsai, SourceForge.net Support

Changed 2 years ago by cambridge

Oh yes, it's not obvious. Perhaps you should make that text bigger and bolder!

Well anyway, another 187 files were pushed to the correct URL that you gave me, but they're still not appearing in the browser. In fact now I get two "Code" icons, one with the correct URL nssdb/code and one with the first URL I tried nssdb/nssdb. The first icon says "No commits to display." and the second says "No (more) commits" and "initing" in the left hand side.

So I don't really want the nssdb/nssdb icon, that's just confusing now. I'd like to see the files I pushed to nssdb/code appearing under the first icon. Not sure why that's blank.

Note: See TracTickets for help on using tickets.