1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #21734 (closed: self-service)

Opened 3 years ago

Last modified 3 years ago

Encountered a 404 error

Reported by: delacuesta13 Owned by: ctsai
Keywords: PEND Cc:
Private: no

Description

HI guys!

I have a problem with sourceforge hosting. I have seen the problem message in others tickets, it's:

An error has been encountered in accessing this page.

1. Server: sigabu.sourceforge.net 
2. URL path: /home/project-web/sigabu/htdocs/beta/public/ 
3. Error notes: NONE 
4. Error type: 404 
5. Request method: GET 
6. Request query string: NONE 
7. Time: 2011-09-20 02:41:26 UTC (1316486486)

Reporting this problem: The problem you have encountered is with a project web site hosted by SourceForge.net. This issue should be reported to the SourceForge.net-hosted project (not to SourceForge.net).

If this is a severe or recurring/persistent problem, please do one of the following, and provide the error text (numbered 1 through 7, above):

Contact the project via their designated support resources.
Contact the project administrators of this project via email (see the upper right-hand corner of the Project Summary page for their usernames) at user-name@users.sourceforge.net
If you are a maintainer of this web content, please refer to the Site Documentation regarding web services for further assistance.

NOTE: As of 2008-10-23 directory index display has been disabled by default. This option may be re-enabled by the project by placing a file with the name ".htaccess" with this line:

Options +Indexes

I have tried everything, like:

1. change permissions(chmod) to 755.
2. edit the .htaccess.

But i can't solve the problem.

I have two .htaccess files:

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule    ^$    public/    [L]
    RewriteRule    (.*) public/$1    [L]
</IfModule>

And

<IfModule mod_rewrite.c>
RewriteEngine On
 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
 
RewriteRule ^(.*)$ index.php?url=$1 [PT,L]
</IfModule>

<IfModule !mod_rewrite.c>
	ErrorDocument 404 index.php
</IfModule>

Options -Indexes

Maybe the problem is in.htaccess, but in my localhost the project works fine.

The project url: http://sigabu.sourceforge.net/beta/

Sorry for my bad english.

Sincerely,

De la Cuesta.

Change History

Changed 3 years ago by ctsai

  • keywords PEND added; problem, 404, htaccess removed
  • owner set to ctsai
  • status changed from new to assigned

Hello,

I suspect that the .htaccess file is behaving in a way you're not expecting. Have you checked the web#Troubleshooting error logs? for more clues?

Thanks,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by ctsai

Oops, I messed up that documentation link, let's try that again: documentation for error logs

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by delacuesta13

Hi Chris,

I could solve the problem easily, but i had to search too.

The solution was add a line in both .htaccess file:

RewriteBase /beta

Thank you,

De la Cuesta.

Changed 3 years ago by ctsai

  • status changed from assigned to closed
  • resolution set to self-service

Thanks for the update.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.