1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #16248 (closed: wontfix)

Opened 3 years ago

Last modified 23 months ago

"Invalid ArtifactID" web page has broken HTML for "find new location" link

Reported by: fingolfin Owned by: ctsai
Keywords: ENGR AT-688 Cc:
Private: no

Description

Surf to this URL to reproduce the bug i question:

http://sourceforge.net/tracker/?func=detail&aid=3149416&group_id=37116&atid=418820

When one tries to an invalid tracker URL (say, because a tracker item was moved from a bugs tracker to a feature request tracker), then SF:net shows an error page with content like this:

There was an error processing your request ...

ERROR
Artifact: Invalid ArtifactID; this Tracker item may have moved to a different Tracker since this URL was generated -- <a href="/support/tracker.php?aid=3149416">[Find the new location of this Tracker item]</a> 

Since recently, the link in there which is supposed to help you locate the tracker item is broken -- it literally shows the text I gave above as output, instead of inserting it as HTML code. So the user does not get a nice link, but instead see the plain HTML. And has to copy&paste the destination URL.

Here is the actual HTML source of that part of the page:

 Artifact: Invalid ArtifactID; this Tracker item may have moved to a different Tracker since this URL was generated -- &lt;a href="/support/tracker.php?aid=3149416"&gt;[Find the new location of this Tracker item]&lt;/a&gt;

Change History

Changed 3 years ago by ctsai

  • keywords ENGR AT-688 added
  • owner set to ctsai
  • status changed from new to assigned

Hello,

Thank you for this report, I've confirmed it and have escalated it to our engineering team for further review.

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by fingolfin

Seems that these days things got worse: The example URL I gave now doesn't lead to a broken message; rather it just leads to a completely empty page (no data returned by the server). Maybe an artifact of the new website theme?

Changed 3 years ago by fingolfin

This issue is still present -- it again shows a web page (unlike in my last comment), but still with broken HTML in it, and thus a broken link. Another example. http://sourceforge.net/tracker/?func=detail&aid=3149416&group_id=37116&atid=418820

Quite frustrating, I must say :/

Changed 23 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

Greetings,

This issue only affects the classic SourceForge system, which we are no longer developing. So while we acknowledge that this bug exists in our system, we are not going to spend the time to fix this. It will eventually disappear when the classic system is phased out. I'm closing this ticket as "wontfix".

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.