1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #16097 (closed: wontfix)

Opened 3 years ago

Last modified 20 months ago

beta file manager doesn't remember download count when moving folders

Reported by: christian_boltz Owned by: ctsai
Keywords: ENGR AT-687 Cc:
Private: no

Description

When moving around a folder via sftp://...@frs.sourceforge.net (for example to a "old_releases" folder), the new "files" page displays zero downloads.

The previous files page remembered the download count even if I moved around files and folders.

Please fix the download counter so that it works even after moving a file or folder again.

Change History

Changed 3 years ago by ctsai

  • status changed from new to closed
  • resolution set to knowledgebase

Hello,

This is expected, both the standard and the Beta statistics both systems try to filter our illegitimate downloads (such as from scripts, bots, misbehaving download managers, etc.). However, the algorithms they use are different, in some cases, the standard system's algorithm is more accurate, in others, the beta is more accurate. In any case though, that is why the numbers do not match up.

Regards,
Chris Tsai, SourceForge.net Support

Changed 3 years ago by ctsai

  • status changed from closed to reopened
  • resolution knowledgebase deleted

My apologies, I typed that response into the wrong tab.

Changed 3 years ago by ctsai

  • keywords ENGR AT-687 added
  • owner set to ctsai
  • status changed from reopened to assigned

Hello,

This is the current intended behavior (please note however, that the download counts still count towards the project's total downloads). However, due to confusion and user demand, I've put in a feature request for the team to change this behavior. I'll let you know how they respond.

Regards,
Chris Tsai, SourceForge.net Support

Changed 20 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to wontfix

I've discussed this with the team again, and after some deliberation, we've made the decision that maintaining the file stats after a rename/move is not feasible due to the way the stats system is designed.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.