1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #10061 (closed: self-service)

Opened 4 years ago

Last modified 4 years ago

relocate repository

Reported by: jzheng24 Owned by: ctsai
Keywords: PEND Cc:
Private: no

Description

MGED project is one sourceforge.net project (https://sourceforge.net/projects/mged/). It's website also hosted by sourceforge.net. We want to update the website. I committed the updated files. For update the website. I login in shell.sourceforge.net.

When I ran 'svn update'. I got following message:
svn: Repository moved temporarily to
'http://sourceforge.net/apps/trac/sourceforge/wiki/Subversion'; please relocate

I tried to relocate by using 'svn switch'. I followed the examples found in the
Internet. Below were the commands and the error messages I got:


command:
svn switch
http://sourceforge.net/apps/trac/sourceforge/wiki/Subversion

error message:
svn: The OPTIONS response did not include the requested
activity-collection-set; this often means that the URL is not
WebDAV-enabled


command:
svn switch --relocate FROM TO
http://sourceforge.net/apps/trac/sourceforge/wiki/Subversion

error message:
svn: 'http://sourceforge.net/apps/trac/sourceforge/wiki' is not a working copy
svn: 'http://sourceforge.net/apps/trac/sourceforge/wiki' does not exist


How can I relocate the repository? Any help are welcome!

Thanks in advance.

Jie Zheng, Ph.D
Center for Bioinformatics
Department of Genetics
University of Pennsylvania

Change History

Changed 4 years ago by ctsai

  • keywords PEND added; svn switch removed
  • owner set to ctsai
  • status changed from new to assigned

Hello,

SVN is not used for the website files. If you wish to update your website, please see our documentation on Project web.

As for your SVN repository, that is for the source code for your project, the address for that is: https://mged.svn.sourceforge.net/svnroot/mged

Does this answer your question?

Regards,
Chris Tsai, SourceForge.net Support

Changed 4 years ago by jzheng24

Thanks for your answer.

After I committed the source code for our project, I used shell connection to the sourceforget.net and ran 'svn update' command which can update the website as those files I committed in our project. It has worked until November, 2009. I tried this time. The problem is that repository relocated. I want to know how I can relocate the repository.

I will try to upload files to update the website.

Regards,

Jie

Changed 4 years ago by ctsai

Hello,

To be clear, when I am referring to the "website" I am referring to this page: http://mged.sourceforge.net/

That space is not managed by SVN. If you are referring to a different page, please clarify so that we can make sure we are talking about the same thing.

Your repository has not changed location, it was, and still is located at https://mged.svn.sourceforge.net/svnroot/mged

What is the URL for your repository that you are trying?

Regards,
Chris Tsai, SourceForge.net Support

Changed 4 years ago by hinojosa

  • status changed from assigned to closed
  • resolution set to self-service
Note: See TracTickets for help on using tickets.