1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #174 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Warning email text is truncated on Windows 7

Reported by: chrfranke Owned by: chrfranke
Priority: major Milestone: Release 5.41
Component: smartd Version: 5.40
Keywords: windows Cc:

Description

When smartd sends a warning email on Windows 7 its text is truncated:

This email was generated by the smartd daemon running on:

    host name: somehost
   DNS domain: somedomain

missing:

The following warning/error was logged by the smartd daemon:

TEST EMAIL from smartd for device: /dev/sda

For details see the event log or log file of smartd. 

Problem does not occur on Windows XP.

Change History

Changed 3 years ago by chrfranke

  • owner changed from somebody to chrfranke
  • status changed from new to accepted
  • milestone set to Release 5.41

The root of the problem is that the printf() formatting in the msvcrt.dll now disables "%n" support by default. This was initially added in msvcrt8.dll and later and was apparently later backported to the msvcrt.dll on Win7 (and likely Vista) but not on XP. MinGW builds use the msvcrt.dll by default. Smartd calls _set_printf_count_output(1) only for MSVC builds. Use of "%n" should be avoided.

Changed 3 years ago by chrfranke

  • status changed from accepted to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.