1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in
Version 43 (modified by funnylife_ma, 3 years ago)

--

The easy way on ubuntu : install from PPA

A ppa for Ubuntu lucid is available on Launchpad. The package is also compatible with Debian testing or unstable

Thr lightspark package contains the standalone player for testing purposes. Most users will be interested in the browser-plugin-lightspark package that offers the firefox/chrome plugin.

The easy way on Fedora

lightspark is available in RPM Fusion for Fedora 13 and above, to install :

- Standalone player : su -c 'yum install lightspark'

- Mozilla plugin : su -c 'yum install lightspark-mozilla-plugin'

Notes:

- People who installed lightspark from the previous repo need to remove the repo by running : su -c 'yum remove lightspark-release'

- Lightspark 0.4.5 will be available only for Fedora 14 and rawhide due to a dependency on libxml++ >= 2.33.1

The easy way on Archlinux

Install lightspark or lightspark-git from the AUR.

The easy way on Gentoo Linux

# sudo emerge -av www-plugins/lightspark

The hard way: install from sources

To install the bleeding edge code for lightspark (be careful, this may void your warranty) use git

  • git clone git://github.com/lightspark/lightspark.git lightspark
  • cd lightspark
  • mkdir build
  • cd build
  • cmake -DCMAKE_BUILD_TYPE=Release -DCOMPILE_PLUGIN=1 -DCMAKE_INSTALL_PREFIX=/usr ..
  • make
  • make install (should be run with root privileges)

Please note the two periods ("..") at the end of the "cmake" command. These should be included, otherwise the command will fail.

The following packages are needed on debian/ubuntu to build the code: cmake, nasm, llvm-dev (>= 2.7) or llvm-2.7-dev, libsdl1.2-dev, libgl1-mesa-dev, libxext-dev, libcurl4-gnutls-dev or libcurl4-openssl-dev, libxml2-dev, zlib1g-dev, libnspr4-dev, libavcodec-dev, libpcre3-dev, libftgl-dev, libglew1.5-dev, xulrunner-dev (>=1.9.2), libgtkglext1-dev, libffi-dev

The following packages are needed on Fedora to build the code: cmake, nasm, llvm-devel (>= 2.7), SDL-devel, libcurl-devel, glew-devel (>= 1.5.4), ftgl-devel, ffmpeg-devel, gtkglext-devel, pulseaudio-libs-devel, fontconfig-devel, pcre-devel, xulrunner-devel (>= 1.9.2), gettext, boost-devel (>= 1.42), libxml++-devel (>= 2.33.1), librtmp-devel. To get them, run : su -c 'yum-builddep lightspark'. Please note that you should have RPM Fusion enabled on your system.

Troubleshooting

See the Troubleshooting page if you have issues