1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #122 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

thumbnails get mixed up sometimes after deleting some photos

Reported by: parafin Owned by: jo
Priority: minor Milestone: 0.9
Component: general Version:
Keywords: Cc:

Description

I can't reproduce this bug reliably, but after deleting several images it usually shows. Both time I noticed it, thumbnail of one random image got copied over the thumbnail of the previous one. First time this random image was the deleted one, so it seemed like I failed to delete it (and maybe deleted some other photo), which is quite dangerous IMHO. Thumbnail restores after entering and exiting darkroom.

Attachments

0002-image-cache-insert-remove-fix.patch (8.3 KB) - added by rip-someday 3 years ago.
added description of the fixed issues

Change History

Changed 3 years ago by tony2001

Please see if you can reproduce this problem with 0.8.

Changed 3 years ago by jsogo

  • milestone changed from --- to 0.9

I have seen this sometimes, but after testing some development in darktable, so in my case it could be because of some wreckage of the db.
It should be checked before closing

Changed 3 years ago by rip-someday

added patch which should fix this issue, also sent email to darktable-devel about it.

Changed 3 years ago by rip-someday

added description of the fixed issues

Changed 2 years ago by houz

  • status changed from new to closed
  • resolution set to fixed

With the new cache this should no longer happen. If it does feel free to reopen this bug.

Note: See TracTickets for help on using tickets.