John, could you pls change that (I honestly don't understand a single word)?
that is horrible and confusing and weird.
Please sacrifice those weird and odd definitions.
Most of all I would like to have a standard function
void InitSensor(port, SensorType) (or SensorInit) where SensorType is ANY type (analog, US, HTGyro, MSSumo, i2cLS, i2cHS and RS485/COM) (i2cHS for future like implemented by RobotC, RS485/COM for legacy HighSpeed)).
No more SensorTouch, SensorLowSpeed, SensorTemperature, SensorLightActive and all that. You may transfer them to kind of sensor types, not sensor initializing functions.
Then I'd wish to have
SensorValue(port, &value) which returns one or more dimensional sensor values, if not specified then returning the real raw values like the former SensorRaw() (0-1023)
Then I wish to have a
which may specify specific units like percent, inverse raw( 1023-0), touch, pulse, edge, normalized or scaled (what ever the latter 2 might be - i'm not supposed to use them EVER) .
That would make the usage VERY much more transparent and logical.
I know that this is VERY much non-Lego-like but very much comfortable for users for the future (legacy functions could be kept unducumented until extincted some day).
I'll add that to the wish list, just for the record :)
NXC CHESS for NXT: http://www.mindstormsforum.de/viewtopic.php?f=70&t=6790
indispensable for NXC + EV3-C: easy + trouble-free network & sensor+motor remote control for rs485, BT, USB!