1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Perl Module Error starting assp v2

Moderators: pdreissen, fribo

Perl Module Error starting assp v2

Postby r_cremer » Wed Mar 06, 2013 5:54 pm

Hello,
great work, thank you.

I moved the install from debian 5 to ubuntu 12lts. It seems that everything is running. But I'm not able to report spam mail to assp-spam@<DOMAIN>, ardess is not known by server. I tried to stop and start assp service and get the following error:

Return::Value is deprecated at /usr/lib/perl5/Return/Value.pm line 13
require Return/Value.pm called at /usr/lib/perl5/Email/Send.pm line 11
Email::Send::BEGIN() called at /usr/lib/perl5/Return/Value.pm line 0
eval {...} called at /usr/lib/perl5/Return/Value.pm line 0
require Email/Send.pm called at (eval 81) line 1
main::BEGIN() called at /usr/lib/perl5/Return/Value.pm line 0
eval {...} called at /usr/lib/perl5/Return/Value.pm line 0
eval 'use Email::Send ;1;' called at sub main::validateModule line 8
main::validateModule('Email::Send') called at sub main::defineCanUseModules line 80
main::defineCanUseModules() called at assp.pl line 5487


On assp setup-page I get the info, some perl modules are not installed:
ASSP_WordStem
Convert::Scalar
Digest::SHA1
Sys::MemInfo
Thread::State
Unicode::GCString


and the PM NetSNMP::agent is 5.0403, but it should be 5.05. This one I can't find.

First I tried to install the PM with apt-get, but I missed a lot. So went to cpan to install all the PM. On commandline I did check with
perl -e "use Sys::MemInfo;"
. This will give no output.

I'm using ASSP version 2.2.2(12343) with Ubuntu 12.04.1 LTS.
Last updates are installed and perl is upgraded with cpan.


Can someone please help on that issiue??
Do I have something to configer I've forgotten?

Many thanks in advance
Ralf
r_cremer
 
Posts: 2
Joined: Wed Mar 06, 2013 5:34 pm
Location: Germany

Re: Perl Module Error starting assp v2

Postby jroper1973 » Sun Jul 07, 2013 1:28 am

I am trying to move my ASSP to a new server and I get a very similar error. I can receive email, but I can not send any.

Fresh install of Ubuntu 12.04
Perl 5.14.2 (default for 12.04)

I've tried 3 different ASSP installations, and get the same general error
I tried a fresh install of ASSP
A migrated copy of V1 from another working ASSP server I have
An upgraded copy of the above install running the very latest V2
Only Perl modules that are missing are the IPV6, MS AD, SNMP, Certificate

Code: Select all
Return::Value is deprecated at /usr/local/share/perl/5.14.2/Return/Value.pm line 13.
required Return/Value.pl called at /usr/local/share/perl/5.14.2/Email/Send.pm line 11
Email::Send::BEGIN() called at /usr/local/share/perl/5.14.2/Return/Value.pm line 0
eval {...} called at /usr/local/share/perl/5.14.2/Return/Value.pm line 0
require Email/Send.pm called at (eval 959) line 1
main::BEGIN() called at /usr/local/share/perl/5.14.2/REturn/Value.pm line 0
eval {...} called at /usr/local/share/perl/5.14.2/Return/Value.pm line 0
eval 'use Email::Send; 1
;' called at assp.pl line 3713
jroper1973
 
Posts: 10
Joined: Tue Aug 21, 2012 2:37 am

Re: Perl Module Error starting assp v2

Postby jroper1973 » Sun Jul 07, 2013 1:59 am

I just got around it by the following:

I basically copied the following directories from the server which was working, to the server which is not. Sorta ghetto... but it seems to work.

/etc/perl
/usr/local/share/perl
/usr/share/perl
/usr/share/perl5

I hope there will be no side effects, for the most part I am a noob.
jroper1973
 
Posts: 10
Joined: Tue Aug 21, 2012 2:37 am

Re: Perl Module Error starting assp v2

Postby thockar » Sun Jul 07, 2013 5:47 am

upgrade assp.pl!

Thomas
thockar
Site Admin
 
Posts: 460
Joined: Mon Mar 09, 2009 7:05 pm


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron