1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Installation

From sconcho

Revision as of 19:14, 18 September 2011 by Haskelladdict (Talk | contribs)
Jump to: navigation, search

In order to use sconcho on your computer you need to install python and PyQt4. We strongly recommend that you install python version 2.7 (python version 3 will not work) and PyQt4 version 4.7 or later. After following the installation steps below you should be able to use sconcho as described in the Downloads section.


Windows Users

Please make sure that your PyQt version matches the python version you installed.


Linux Users

Most Linux distributions should come with python installed by default. In addition, many Linux distributions (such as Gentoo, Ubuntu, Debian) offer PyQt4 in their repositories. Installing python and PyQt4 should therefore be straightforward in most cases.


Mac OSX Users

NEW: There is an experimental sconcho app bundle available for Intel Macs (G4 or G5 won't work) on the download site. So far it has only been tested on a 64 bit version of Mac OSX Snow Leopard (10.6). Please give it shot and let us know if it works for you or not.

If the app bundle fails, the easiest way to use sconcho on Mac OSX for the time being is via macports[1]. Once you have macports on your computer, install the package py27-pyqt4 and change the first line of sconcho.pyw from

#!/usr/bin/env python

to

#!/usr/bin/env python2.7

That should be all. In the future I am planning on offering a native sconcho bundle. If somebody can help with that please let me know.

Personal tools