1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Installing PDL on Ubuntu 11.10 Oneiric Ocelot

From pdl

Revision as of 20:22, 14 January 2012 by Csobchuk (Talk | contribs)
Jump to: navigation, search

These instructions apply to Ubuntu 11.10 Oneiric Ocelot, but they will most probably be useful for other Ubuntu versions from 10.10 onwards. For this installation to work your computer must have access to Internet. Make sure you do have access to the internet by visiting some known web page with Firefox.

The newer Ubuntu releases have a bug where the PGPLOT module is not installed correctly. Use the following to install the prerequisites. Using a command prompt type:

sudo apt-get install gfortran libextutils-f77-perl libx11-dev

sudo apt-get install pgplot5

sudo apt-get install libpgplot-perl

sudo apt-get install pdl

To install the latest PDL on Ubuntu will require using cpan to upgrade our environment. Using a command prompt type:


sudo cpan

upgrade /PDL/

quit

You should now be able to type in the same command prompt:

pdl2

and be presented with the pdl2 shell.

Personal tools