1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000054 [FiniteArea] major always 2011-02-08 19:51 2011-03-02 23:51
Reporter Bgschaid View Status public  
Assigned To Bgschaid
Priority normal Resolution fixed  
Status resolved  
Summary 0000054: faMatrix::setValues messes up the solution
Description When using fooEqn.setValues(....) the solution is set in the faces but strange artefacts appear in other faces
Additional Information The problem is that the code from the fvMatrix.setValues was adapted, but in there the iteration over a cell yielded the faces which is the correct entity to get the off-diagonal elements of the matrix. The imilar iteration over a face yields the points. But the edges are needed.

I pushed the branch bugfix/faMatrixSetValuesBranch with a fix to the git. The commit in question is
http://openfoam-extend.git.sourceforge.net/git/gitweb.cgi?p=openfoam-extend/OpenFOAM-1.6-ext;a=commit;h=e3b92c995d98e1636b5bc308fc5f0b7114e5b581 [^]
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000150)
Bgschaid (administrator)
2011-03-02 23:51

Fix got merged but bug was never closed

- Issue History
Date Modified Username Field Change
2011-02-08 19:51 Bgschaid New Issue
2011-03-02 23:51 Bgschaid Note Added: 0000150
2011-03-02 23:51 Bgschaid Status new => resolved
2011-03-02 23:51 Bgschaid Resolution open => fixed
2011-03-02 23:51 Bgschaid Assigned To => Bgschaid


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker